Searching...
December 14, 2011
Wednesday, December 14, 2011

[FIX] msfupdate (no version information available)

Beberapa hari yang lalu saya mendapatkan pesan error ketika sedang meng-update metasploit. Kira-kira pesan error-nya seperti ini:



svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)






Perhatikan "no version information available", error di sini berarti library metasploit tidak memiliki versi yang dimaksud. Untuk itu, coba cek file library nya:




libssl.so.0.9.8 tidak memiliki link ke /usr/lib/ dimana seluruh library bergantung pada direktori ini. Begitupun nasib libcrypto.so.0.9.8. Maka yang perlu kita lakukan adalah:


  1. Backup library msf yang error
  2. Buat link antara library msf yang error dengan library yang ada di /usr/lib/
Berikut caranya:


root@rx:~# cd /opt/framework/lib/
root@rx:/opt/framework/lib# mv libcrypto.so.0.9.8 libcrypto.so.0.9.8.bak
root@rx:/opt/framework/lib# mv libssl.so.0.9.8 libssl.so.0.9.8.bak
root@rx:/opt/framework/lib# ln -s /usr/lib/libcrypto.so.0.9.8
root@rx:/opt/framework/lib# ln -s /usr/lib/libssl.so.0.9.8




Jika sudah, coba jalankan msfupdate:


root@rx:~# msfupdate




SUKSES. Like usual (PERFECT) (=


created-by:
Blue Dragon

2 comment:

Post a Comment

 
Back to top!